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HYPACK SHELL

• User-defined buttons or tools can now be added to custom toolbars. The Customize 
dialog used for toolbar customization now includes the User Tools Category, where any 
user-defined buttons are listed and can be added to the toolbar. These user-defined 
buttons are used to launch external executable files.

To create a user-defined button or tool to launch an external program from HYPACK:

1. From the HYPACK Shell, click Tools -> Setup to open the Tool Options window.
2. In the Tool Options window, click [Add] to open the Tool Properties window.
3. In the Tool Properties window, fill out the program's name, select the executable file from 

your device, and enter any parameters that need to be passed to the executable on 
initialization. Click [OK] in Tool Properties, then [Close] in the Tool Options.

The new user-defined tool can be accessed from the Tools menu.

To add the user-defined button to a customized toolbar:

1. From the HYPACK Shell, right click on the top toolbar -> Customize to open the 
Customize window.

2. In the Commands tab, click User Tools under the Categories list on the left. All user-
defined tools will be listed in the Commands list on the right.

3. Click the user-defined tool and drag and drop it in the custom toolbar of your choice. The 
user-defined tool name will appear in the custom toolbar.
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• TIN files created in the TIN Model program can now be displayed in the main area 
map in the HYPACK Shell. They are accessed in the Project Items tab in the Project 
Files -> Background Files folder. 

You can also change how the TIN model drawing style by right clicking on the file -> Style, 
and clicking Points, Hollow, or Filled.

The following images show examples of the display if Points (left), Hollow (center), or 
Filled (right) are selected.

• Removed the View Log Window menu item from the File menu in HYPACK Shell. 
This was an unmaintained window and did not show useful information to the user. The 
following images show the File menu before (left) and after (right) the removal the View 
Log Window option.
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PREPARATION

BACKGROUND CHARTS

OPENSTREETMAPS

• All projects now automatically contain a Dynamic OpenStreetMaps file within the 
Background Files folder. When checked, OpenStreetMaps is automatically 
displayed (sometimes with a slight delay) in the map view of the HYPACK Shell. 
Zooming in and out with the mouse scroll wheel or zoom functions in HYPACK Shell will 
pull in additional maps to display. This file is stored on your device at C:\HYPACK 
2024\Projects\Project Name\Dynamic OpenStreetMaps.

In addition to the HYPACK Shell, OpenStreetMaps can be enabled and displayed within 
other HYPACK programs including HYPACK SURVEY, HYPLOT, and editors. The below 
examples show the OpenStreetMaps chart within MBMAX64 (top) and HYPLOT MAX 
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(bottom).

• We've added the Explore OpenStreetMaps widget, which allows users to export 
part of the OpenStreetMaps as a *.tif file for use as a background chart.
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To use this new feature, from the HYPACK Shell click Widgets -> Explore 
OpenStreetMaps to open the Custom Map dialog.

Select the map source (currently OpenStreetMaps is the only one available), enter the 
location using X/Y or Lat/Long coordinates, then click [Search Location]. You can zoom in 
and out using the mouse scroll wheel or the slider at the bottom of the window. Click 
[Export Map], then give your file a name. The file is saved in the project folder by default.
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Back in the HYPACK Shell in the Project Items tab, click Options and select Rescan 
Folders. The new OpenStreetMaps chart should appear in Background Files, where you 
can enable to display in the map view.

HARDWARE

SURVEY DEVICE DRIVER UPDATES

• Gps.dll: Added the “Ignore ZDA Date” option in the Advanced device settings to 
overwrite the ZDA string date with the PC/computer date. This option was added to 
support end of life GPS units that are experiencing GPS week number rollover (WNRO) 
issues.

Please note that unless specifically instructed by the HYPACK Technical Support Team, 
leave this option unchecked.

To use this new feature:
1. From the HYPACK Shell, click Preparation -> Hardware Setup.  The HYPACK Combined 

Hardware window appears.
2. Add the gps.dll driver, then double click on the GPS NMEA-0183 driver to open the Setup 

window.
3. In the Setup window, click [Advanced]. The Advanced options window appears.
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4. Check Ignore ZDA Date, then click [OK].

• Cutfill.dll: Added a drop-down box in the cutfill.dll Setup dialog to select the tide 

source, which users can designate either the global tide from HYPACK® SURVEY 
or a specific mobile as the tide source.

The mobiles listed under the Tide Source dropdown will depend on what is added in the 
HYPACK Combined Hardware. In this example, you can select from Dredge, Arm, and 
Spud, which correspond with the mobiles that are added in the following HYPACK 
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Combined Hardware image.

Note that Tide Source interacts with the Individual Tide Per Mobile checkbox in the 
HYPACK Survey options in the System tab at the Hardware level. Individual Tide per 
Mobile enables you to use multiple tide devices - up to one for each mobile in your 
configuration. When this option is checked, any mobile without a tide device assigned to it 
will inherit the tide of the main vessel.

So, if Individual Tide Per Mobile is checked:
> If Global is selected in Tide Source, the Cut Fill Monitor window will display the tide 

from the mobile on which the device is installed.
> If a mobile is selected and it has a tide device, then the tide reading from that device 

will be used.
If Individual Tide Per Mobile is unchecked:
> If Global is selected, the Cut Fill Monitor window will display the global tide from 

Survey.

To use the Tide Source option:
1. Add your mobile, give it a name in the Mobile Name field, and click File -> Save. 

This adds the name of the mobile to the Tide Source drop down in the CutFill driver Setup 
window.

2. Add the tide device(s) to each mobile that has one.
3. Add cutfill.dll to the appropriate mobile.
4. Double click on the Cut Fill Monitor driver to open the Setup dialog, then pick your Tide 

source and click [OK].
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• Subbot.dll: Added support for the GeoAcoustics GeoPulse Compact sub-bottom 
sonar. To use this device in HYPACK, in the HYPACK Combined Hardware add 
subbot.dll (Sub-bottom Driver) to your vessel, then in the Setup window, select 
GeoAcoustics GeoPulse from the Devices list as shown on the left. Then, go to the 
Survey Device tab, then configure the Connection Type as shown on the right.

For additional information, refer to GeoAcoustics GeoPulse Compact Support Added to 
HYPACK by Daniel Tobin.

• Aistide.dll: Driver now reads VDM and VDO messages.

DREDGEPACK®DEVICE DRIVER UPDATES

• Mobileconnect.dll: The Mobile Connect window has been updated with color and 
transparency selections for the outline and fill of the mobile connect arm. Users can 
also specify the start and end width of the connection.
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The Mobile Connect driver was developed to connect the trunnion (origin point) on a 

dredge to the cutter head in the DREDGEPACK® map display to illustrate the physical 
connection and changing length of the ladder as it moves.

To use these new features:
1. In HYPACK Hardware, add the mobileconnect.dll to the dredge mobile.
2. In the HYPACK Shell, Open Survey -> DREDGEPACK. The HYPACK Mobile Connect 

window appears.
3. For the outline of the arm, you can adjust the width (0 to 10 pixels wide), color (custom or 

preset), and transparency.
4. Check the Solid Fill box to apply a fill to the inside of the arm. You can adjust the color 

(custom or preset) and transparency of the fill.
5. At the bottom of the window, adjust the width of the start (trunnion/origin point) and end 

(cutter head) of the mobile connect arm by typing in a number or using the up and down 
arrows.
The following image is an example that shows the settings in the Mobile Connect window 
and the corresponding dredge arm.

• Excavator.dll: Added the Smooth Channel Option, which when enabled calculates 
and draws straight line segments instead of a step-like line for the channel’s slope.
To use this new feature, in the HYPACK Hardware add excavator.dll. Open the device 
driver setup window, then click on the Profile/Shapes tab and check the Smooth Channel 
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box.

The example below shows the Excavator interface with the Smooth Channel option 
unchecked (left) and checked (right).

SURVEY

• Users can now convert *.mxb to *.mtx files directly in HYPACK® SURVEY and 

DREDGEPACK®. *.mxb files are backup binary versions of the matrix files created at 
user-defined time intervals while surveying. These *.mxb files can be used to restore your 
project *.mtx file to the state it was at the time the file was generated, which ensures 
security against data loss.
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To use this new feature, in HYPACK® SURVEY or DREDGEPACK®, click on the Matrix 
tab in the toolbar and click Convert .mxb -> .mtx, and the Open dialog appears. 

In the Open dialog, click on the *.mxb file and click [Open]. In the Save As window, give 
your *.mtx file a name, then click [Save]. A new matrix file will be loaded and drawn on the 
map, and you can continue with your surveying.

For additional information, refer to Converting MXB Files to MTX in DREDGEPACK® by 
Jocelyn Kane.

REAL TIME CLOUD

• Users can now modify target size and style in the Real Time Cloud program.

To use this new feature, first launch HYPACK® SURVEY, then click Options -> Shared 
Memory -> HYPACK Real Time Cloud. In the Real Time Cloud window, click View -> 
Settings to open the Settings dialog. In the Targets drop down menu, select from the 
following options: None, Point, Circle, Cylinder, MBMAX64, and Flag. You can also adjust 
the size of the targets from the Size field.
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As a reminder, here are how the target styles appear. From left to right, top to bottom, the 
target styles used are Point, Flag, Circle, Cylinder, and MBMAX64.

POST-PROCESSING

64-BIT HYSWEEP® EDITOR (MBMAX64)
• KMALL and ALL files now calculate RTK tides when loaded into MBMAX64 if an 

RTK method is selected in the RTK Tide Method section of the Geodetic 
Parameters dialog in the HYPACK Shell. If “Not Using RTK Tide” is selected, no 
ellipsoidally-referenced tides are calculated.

FINAL PRODUCTS

ENC EDITOR

• Removed the Geodesy option from the Environment drop down menu since this 
executable is no longer linked in the ENC Editor. Instead, set the geodesy from the 
HYPACK Shell by clicking Preparation -> Geodetic Parameters.
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Previous (left) and current (right) versions of the Environment drop down menu

UTILITIES

GEODETIC LIST CONVERSION

• In the Geodetic List Conversion Program, three depth inversion options have been 
added to the Other drop down menu:
> Invert and Meters to Feet - Invert depths and convert units from meters to feet (ex: m 

to -ft).
> Invert and Feet to Meters - Invert depths and convert units from feet to meters (ex: ft 

to -m).
> Invert Depth - Invert depths only (ex: d to -d).

To use these options, from the HYPACK Shell click Utilities -> Geodesy -> Geodetic 
List Conversion to open the Geodetic List Conversion dialog.

In the following example, Invert Feet to Meters is selected, and the depth value from 
the input file (50.40 ft) is inverted and converted to meters (-15.36 m) in the output file.
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