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PREPARATION

HARDWARE

SURVEY DEVICE DRIVER UPDATES

• POSMV.dll: 
We’ve added the capability to use Group 1 codes back to the driver setup with the 
new frame data options. We recommend selecting Group 102, which logs multibeam 
frame data. Selecting Group 1 records vessel frame data, and we recommend using this 
option only if Group 102 is unavailable.

To select the Frame data source:
1. From the HYPACK Shell, click Preparation -> Hardware Setup to open the HYPACK 

Combined Hardware window.
2. Select posmv.dll from the Available drivers list, then click [Add -->].
3. Double click on the Applanix POS M/V driver from the Installed list. The Applanix POS M/

V Setup window appears.
4. Select your options. Under Frame data, choose between Group 102 and Group 1, then 

clik [OK].
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DREDGEPACK®DEVICE DRIVER UPDATES

• HopperDQMSender.dll:
Added the Pass-through Mode checkbox in the HopperDQMSender driver setup 
window. When this box is checked, this mode will look for data via serial or network, and 
if it receives something, will verify that the data is valid, add the Plant ID to the XML, and 
send the data via DQM Direct. The status and data tabs will not be visible on the runtime 
window. The user will only see the outgoing string, the time of the last message received, 
and the result of the DQM Direct send.

DATA ACQUISITION

SURVEY
• Fixed a bug where customized toolbar settings in the Survey window were not 

saved after closing Survey. Replaced both Toolbar menu options (Main Form and Map 
Windows) with the built-in toolbar customization window. Selecting these menu items will 
popup the customize dialog, where different sub-toolbars can be turned on and off.

To customize and turn toolbars on and off in the main Survey window, click Window 
-> Toolbox, and the Customize window opens. From the Toolbars tab, you can enable and 
disable toolbars, create new toolbars, rename and delete custom toolbars, and reset the 
default toolbars. To add more features to a toolbar, navigate to the Commands tab, and 
click, drag, and drop each command icon at the desired location on the toolbar. To 
remove a tool from the toolbar, while the Customize window is open, click and drag the 
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icon off the toolbar.

To enable and disable toolbars in the area map window, right click on the grey toolbar 
and click on the name of the tools or toolbar you want to add or remove. To customize 
toolbars in the area map window, click Customize, and the same Customize window 
described previously appears.

Tip: When you are dragging a tool from the Commands box to the toolbar, make sure the 
insert indicator appears - the tool you are dragging will be placed in that position.
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REAL TIME CLOUD

• Added option to display the water column data in Real Time Cloud. To enable check 
the option on the Settings dialog. To set coloring change the color table used for the 
intensity colors (cloudInt.hcf by default).

DATA PROCESSING

64-BIT SINGLE BEAM EDITOR (SBMAX64)
• We made a number of updates and bugfixes to the Offline Statistics window:

> Added the Depth 1 and Depth 2 check boxes to choose either or both depths.

> The number of points sometimes wrote on top of “Number of Points”, this has been 
fixed.

> Fix wrong line in graph being used to determine where to print max points.
> Updated start line to use in calculations every time data changes, so switching 

between Current Line and All Lines now updates correctly.
> Catch when line is changed in editor file list and update calculations.

ECHOGRAM WINDOW

• The [Export] button in the Echogram window now opens the Export dialog, which 
has additional functionalities.
When users export signal intensity data as ASCII *.txt files, they have the option to 
choose which depth data to export, as well as whether they want to export data 
from the currently displayed line or all lines. Users can now also export screenshots 
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of the echogram as *.jpg files through the SBMAX64 echogram window.

To us these new functions, you will need to first load at least one *.raw file and open the 
data in the echogram.

From the HYPACK Shell click Processing -> Single Beam Editor (64 bit), and the 
SBMAX64 window opens. Click Load Survey, and in the Raw folder select the LOG file 
and click [Open]. Click any of the *.raw files in the Catalog window, then click [Select] or 
[Select All]. In the Read Parameters window, click [OK]. Back in the SBMAX64 window, 
click [Echogram] to open the echogram window(s).

Once in the Echogram window, click [Export]. The new Export window allows users to 
select the File Types (*.txt or *.jpg) they want to generate. If Samples (.TXT) is selected, 
users can further choose if they want to export data for Depth 1, Depth 2, or both, as well 
as whether they want to export data for the current line or all lines. Click [OK], and the 
Select Folder dialog appears. Choose the desired folder to save the exported files, then 
click [Select Folder]. Within each *.txt file, the program exports each sample as a number, 
and data is grouped into rows by ping.

In the following example, both depths are selected and the output files each contain 
intensity data from a single depth channel. File names are in the format of 
RawFileName.RAW_Channel#.txt.
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If you choose Image (.JPG), a different Save dialog will appear. Choose the desired 
location to save the exported image, then click [Save]. The output will be an image 
capture of the graph from the echogram window.

SB SELECTION

• The Sounding Selection program has new sounding selection options: Start Gate, End 
Gate, Include First Point, and Include Last Point.
> Start Gate - Set the starting distance along the line where soundings will start being 

selected. For example, if you do not need the first bit of data because it is too far from 
your trackline, you could set the Start Gate value to 200 m. If left blank, no start gate 
will be used.

> End Gate - Set the distance beyond which no more soundings are selected. If left 
blank, soundings will be selected through the end of the line.

Previously, when selecting by Distance, the Sounding Selection program did not take into 
account the first and last points of the data file. We've added these as options:
> Include First Point - Enable to keep the original starting point of the line.
> Include Last Point - Enable to keep the last very point of the line.
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To use these new options:
1. From the HYPACK Shell, click Processing -> Sounding Selection -> SB Selection. The 

Sounding Selection window opens.
2. On the left toolbar, make sure the Distance checkbox is checked. You can type in values 

for Start Gate and/or End Gate, and check or uncheck the Include First Point and Include 
Last Point boxes.

3. Click [Apply Settings] to apply these settings to your sounding selection.

The following example shows how these new sounding selection options are applied. 
Include First and Include Last Points are enabled, and so both points are selected 
(contrast this with the previous image where these options are not checked). Start Gate 
and End Gate are set to 200 and 850, respectively, and soundings from in between these 
two distances are selected.

REAL-TIME MOSAIC FOR SIDE SCAN DATA

• The Real-Time Side Scan Mosaic Settings dialog has received a slight UI update. 

Users will also receive a warning and are sent back to the Real-Time Side Scan Mosaic 
Settings dialog if the resolution is too low.
8



• Bugfix: Previously, changing resolution and clicking “No” when it asks to delete old 
mosaics causes old mosaics to be drawn offset. GeoTIF files are now created at the right 
location.

SIDE SCAN PROCESSING

TARGETING AND MOSAICKING BETA

• The Side Scan Targeting and Mosaicking Beta (SSTM) now supports loading 
backscatter exports from MBMAX64 in the HS2x format. We’ve also added a new 
gain option that works great with backscatter (Angle Varied Gain, across all lines). Refer 
to our article Backscatter Update for Side Scan Targeting and Mosaicking by Daniel Tobin 
for more information.

• The Optimal Resolution Calculator has been greatly simplified to display only two 
fields, Range and Horizontal Aperture in degrees, since these are the only values 
used to calculate the suggested resolution.

To use the new Optimal Resolution Calculator:
1. From the HYPACK Shell, click Side Scan -> Targeting and Mosaicking (Beta). The Side 

Scan Targeting and Mosaicking Beta window appears.
2. Load some data, then click Tools -> Resolution Calculator. The Optimal Resolution 

Calculator window opens.
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Note you can also open the calculator by selecting the Mosaic tab, then clicking on the 
calculator icon under the Lines list.

3. The current dataset's range should be listed. If the dataset's sonar has an entry in our 
database, the Horizontal Aperture field should be accurately filled. Otherwise, it uses the 
default of 0.5.

NOTE: Only the 64-bit version is included. There is no support for the 32-bit version due its 
lower memory limits.

64-BIT HYSWEEP® EDITOR (MBMAX64)
• The [Update Filter Preview] button in the Search and Filter Options window has 

been changed to [Update] to avoid confusion about filters. Since filters are always 
precalculated regardless whether the filter preview (marked with yellow X’s) is enabled or 
not, these options are applied to the filters. To view this change, in MBMAX64 click Edit -
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> Search and Filter Options, and view the different tabs. The MBMAX64 interface also 
uses “Filters” for the status labels instead of “Filter Preview”.

ADCP PROFILE

• The Save to XYZ option has been added to the ADCP Profile program. Users can 
now directly output XYZ bathymetry data from All format files, ADCP files (*.ADP, *.000), 
and SonTek files (*.YDFF, *.RIV, and *.RIVR).

To us this new feature:

1. From the HYPACK Shell click Utilities -> ADCP -> ADCP Profile.
2. Load your data files by clicking File -> Open.
3. In the ADCP Profile window, click File -> Save to XYZ. The Select Folder for Export 

window appears.
4. Click on the folder name where you want to save files to, then click [Select Folder].

All XYZ files are now saved to the selected folder.
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FINAL PRODUCTS

HYPLOT MAX
• Users can now zoom to where individual project files appear on the map area. If a 

project file in the Charts (Map Area) section on the right is enabled and highlighted in 
blue, right click on it and select the Zoom Extents option.

> Any enabled item may be right clicked to reveal the option, but the item highlighted in 
blue will be focused.

> This action may only be performed on individual items, not on categories or groups of 
multiple items. For groups of items, use the Zoom Extents button on the top bar.

TIN MODEL

• Added the Single Beam Depths option to the Initial Data window. This option only 
displays for files with single beam data. When loading edited log or HS2x files, you can 
choose to load Depth 1, Depth 2, or All Depths.

To select the Single Beam Depths you want to use when building your TIN model:
1. From the HYPACK Shell, click Final Products -> TIN Model. The TIN window opens.
2. In the TIN window, click File -> New. The Initial Data window appears. 
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3. Click [Main Input File] and select your single beam edited log (*.EDT) or HS2x files. The 
Single Beam Depths option is available if you selected single beam data.

4. In the remaining fields, enter any additional files needed for your output goal.
5. Select Depth 1, Depth 2, or All Depths from the dropdown, then click [OK] to generate the 

TIN model.

UTILITIES

DATA CONVERTER

• Added the On Towfish checkbox to the ...To HSX tab in the HYPACK HSXConverter 
window. While checked, any HSX files generated from JSF files will have draft values, 
which are read in MBMAX64 when the converted HSX file is opened.

To use this new feature:
1. From the HYPACK Shell, click Utilities -> File Work -> Data Converter. The HYPACK 

HSXConverter window appears.
2. Navigate to the ..To HSX tab and click [Setup]. The Settings window appears.
3. In the Settings window for the Edgetech JSF Setup, check the On Towfish checkbox to 

enable the pressure or depth values parsed from the JSF to serve as the draft values that 
are read from the HSX file in MBMAX64.
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